MR400 Festplatte clonen

Ein herzliches Hallo an alle!

Kurz zu mir: Ich bin Telekom “Profi” und verkaufe unter anderem auch das Zeug´s was ich hier selber nutze. Insoweit hoffe ich, zu dem einen oder anderen Thema Hilfe anbieten zu können.
Ich beschäftige mich beruflich aber hauptsächlich mit professionellen BKS (Bürokommunikationssytemen) und damit in Zusammenhang stehenden Geräten. In meiner Freizeit stehen PC´s, Netzwerke und alles was da dran hängt ziemlich weit oben auf der Liste. Doch nun zu meinem Problem:

Ich möchte die originale 500 GB HD gegen eine 2 TB austauschen und natürlich die reichlich 400 GB Aufnahmen mitnehmen.
Jetzt habe ich das Problem, dass die originale HD von Win7 nicht erkannt wird. In der Datenträgerverwaltung wird die Platte fehlerfrei als primäre Partition, aber ohne Dateisystem gezeigt. Im Explorer damit logischerweise nicht. Die üblichen Verdächtigen (EaseUS, Clonezilla etc.) fallen damit weg.
Daraufhin habe ich den Rechner über eine Linux CD mit GParted gestartet. Hier wird diese Platte sauber erkannt, allerdings mit nur 7,38 GB Datenbesatz, der Rest frei. Das Clonen wird nach wenigen Sekunden mit einer Fehlermeldung abgebrochen. Zunächst hatte ich den Verdacht, das mit einem der letzten Updates dem ganzen ein Riegel vorgeschoben wurde oder die HD einen “Schmiß” hat. Das kann ich aber inzwischen ausschließen. Im Receiver läuft die originale weiter tadellos mit allen Aufnahmen.
Ich habe die neue 2TB Platte im Receiver gestartet und diverse kurze Aufnahmen gemacht (einfach genial 540 Std HD-Aufnahmekapazität ;0))) ). Danach wird die Platte aber auch im PC sauber erkannt und mit der erwarteten Ordnerstruktur auch im Explorer dargestellt, demnach ist nichts firmwareseitig blockiert.

Hat einer von Euch eine Idee, was ich noch tun könnte. Und bevor einer die Stirn runzelt, ich habe die gleiche Frage auch im ip-TV Forum gestellt… weil ich einfach die Reichweite erhöhen will.

Für jegliche Hilfe bin ich dankbar.

Liebe Grüße aus Oberfranken
Papa Bear

Ich hatte drüben ja schonmal vorsichtig geantwortet, können aber auch hier weitermachen :slight_smile:
Neben der Fehlermeldung von gparted wäre auch einfach mal interessant, was dir unter Linux denn so als Festplatteninhalt angezeigt wird. Also z.B. mal die Ausgabe von fdisk -l und dann mal mounten und df -h sowie du -hs * auf den Mountpfad.
Denn geschützt ist da eigentlich nichts. Lediglich die Videodateien selbst sind je nach Sender verschlüsselt.

Aber dass die neue Platte jetzt eine NTFS Partition hat ist verrückt!? Also ich hab mittlerweile keinen MR400 mehr da, aber bisher war das immer ext4 und da auf der Kiste Linux läuft ist NTFS auch sehr ungewöhnlich. Ich könnte mir jetzt vorstellen, dass er nimmt, was er bekommt - d.h. wenn da NTFS formatiert vorhanden ist, er nicht neu formatiert. Aber wenn er formatiert, würde ich ext4 erwarten. Kannst sonst auch mal einen Werksreset machen (per Netzschalter ausschalten, Stift auf die Reset Taste drücken und halten, Einschalten bis Zurücksetzen im Display erscheint), das sollte die Festplatte Zwangsformatieren und dann würde ich eine ext4 Partition erwarten.
Aber gut, am Ende ist wohl wichtiger die Daten von der alten Platte zu übertragen und da würde ich dann die NTFS Partition löschen, die von der 500er Platte rüberkopieren, erweitern und das Dateisystem erweitern - so ist zumindest das übliche Vorgehen.

O.K. machen wir hier weiter: Zunächst Danke, für Deine Antwort. Du hattest Recht, der MR400 behält, dass ihm vorgesetzte Dateisystem offenbar bei. Ich hatte jetzt die 2TB Platte im Receiver und einen hardreset gemacht. Sie wird jetzt genau so behandelt, wie 500 GB (ohne Dateisystem mit 1,83 TB in der Datenträgerverwaltung angezeigt. das bedeutet aber wohl gleichzeitig, das GParted beim Löschen das Dateisystem nicht anfasst?
Ich bin jetzt nicht der Linuxnerd, sondern eher der ahnungslose Anwender und meine DOS-kenntnisse (das erinnert mich zumindet daran) sind nach so vielen Jahren auch nur noch rudimentär vorhanden.
Ich pobiere das ganze jetzt einfach nochmal, eventuell kommen die Kopierabbrüche vom falschen Dateisystem auf der Zielplatte…
Ich melde mich wieder.

LG aus Oberfranken

Papa Bear

So: Jetzt hatte ich das ganze Procedere nochmal mit GParted probiert. Beide HD´s wurden erkannt, Quelllaufwerk copy - Ziellaufwerk löschen - paste… 4 -5 Sekunden Fehler und Abbruch. Die Logdatei habe ich abgespeichert, aber, eben Linux, ich habe keine Ahnung wo die ist ;0))
Jetzt habe ich mir diverse Clone-Programme angeschaut und musste feststellen, dass nahezu alle Geld kosten, wenn man die Option HD clonen nutzen will.
Jetzt im Moment läuft der Kopiervorgang mit HD Clone 7.2 (das hatte ich noch auf einer DVD rum fliegen), Dauer ca. 4,5 Stunden. Mal sehen, was mich erwartet.

LG aus Oberfranken
Papa Bear

Das Klonen hat einwandfrei funktioniert. Jetzt habe ich zwei 500GB HD´s ;0))
Ich muss mir Morgen mal anschauen, ob ich mit GParted die Partition händisch anpassen kann.
Weiß hier jemand welche Partition das ist?

LG aus Oberfranken

Papa Bear

Ja also vermutlich musst du jetzt erst die Partition vergrößern und dann das Dateisystem drin.
Das sollte mit gparted problemlos funktionieren.

Wieviel hast du denn zur Auswahl? :wink:
Notfalls mach ein Bild, damit sollte es hinzubekommen sein :slight_smile:

Hallo,

Du hattest narürlich wieder recht. Es ist ja nur eine Partition. GParted zeigt sie eigenartigerweise als ext2 an und sagt mir, innerhalb dieser Partition 1,36 TB ungenutzter Bereich. Das Dateisystem lässt sich aber nicht erweitern. Das ganze wird ja mit einer Überprüfung gestartet. Diese wird ebenfalls nach wenigen Sekunden abgebrochen…

Puhh!

Hm, dein gparted scheint auch etwas die Arbeit zu verweigern. parted verweigerte wohl früher das Vergrößern von ext4 mit “Error: File system has an incompatible feature enabled.” evtl hast du noch ne alte Version und ist das die Fehlermeldung die du bekommst? Spielt im Grunde aber auch keine wirkliche Rolle. Die Tools des Dateisystems sind für ext2-4 eh die gleichen.

Probieren wirs mit Alternativen für die Partitionierung. Was gibt denn fdisk -l aus? Bin mir nicht so sicher, ob innerhalb der Partition 1,36TB ungenutzt sind, oder nicht eher auf der Festplatte 1,36TB nicht partitioniert sind.

Würde mich wundern, wenn das Clone Programm die Partition vergrößert hätte. Sollte das aber wirklich so sein, kannst du einfach mit resize2fs /dev/… das Dateisystem auf die Partitionsgröße anpassen.

Wenn die Partition noch vergrößert werden muss, musst du sie mit fdisk löschen und neu anlegen (gleichen Startsektor verwenden).
fdisk /dev/…
Dann p drücken und sicherheitshalber noch mal kontrollieren, dass es die richtige Festplatte ist und nur eine Partition da ist. Den Startsektor auch mal merken. Mit F müsste dir der nicht partitionierte Speicher von 1.36TB angezeigt werden, falls nicht, müssen wir hier noch mal über die fdisk -l Ausgabe reden :slight_smile: Ansonsten gehts los: d drücken und die Partition 1 löschen. Dann noch mal p und es sollte keine Partition mehr da sein. Dann mit n eine neue Partition anlegen, p drücken für Primär, 1 drücken für 1. primäre Partition, dann will er den ersten Sektor wissen, der default Wert ist wahrscheinlich der, der vorher bei der alten Partition der Start Wert war, dann mit Enter bestätigen, sonst den alten Startwert eintippen. Dann will er die Größe wissen, Standard ist zu nehmen was da ist, das sollte bei dir passen, also noch mal mit Enter bestätigen. Noch mal mit p kontrollieren, ob alles passt. Dann mit w die Partitionierung schreiben. Mit resize2fs wie oben beschrieben das Dateisystem vergrößern und damit solltest du hoffentlich den vollen Platz nutzen können.

Warum so kompliziert. Ich habe das ganze mit Acronis True Image umgesetzt. Platte vom MR an den PC gesteckt. Imagebackup erstellt. Neue Platte dran - Image Backup zurückgespielt - neue Platte in den MR und läuft.

Lieber peepy0402,

Warum so kompliziert? Weil sowohl Acronis, als auch HD Clone aus der 2 TB Platte eine “verkappte” 500 GB Platte machte. “Verkappt” deshalb, weil bei mehrfachen Versuchen zwar eine 1,82 TB Partition gelassen wurde, aber das Dateisystem ums Verrecken nicht anzupassen war (MR erkennt nur 500 GB)
Nun hat es aber geklappt, mit Umweg, aber perfekt.
Ich habe mir die Knoppix CD in den Rechner geladen (hier ging Gparted im ersten Anlauf auch nicht, der MR 400 hat nach dem kopieren die HD nicht erkannt). Dann mit Clonezilla eine 1 zu 1 Kopie erstellt (dieses mal mit echter 500 GB Partition auf der großen Platte) und anschließend mit Gparted die Partition auf´s Maximum erweitert.
Knapp 500 Stunden HD-Aufnahme ist schon cool ;0))))

Danke für die helfenden Hinweise, die mich letztlich nicht aufgeben lassen haben!

Liebe Grüße aus Oberfranken

2 Like

Hi guys, sorry for my language, hope you can help me.
I have problem with my MR 400 black
Just wondering, could you help me, do you know what HDD inside, I will try to change it, but currently, don’t know which model and Product Number is inside…
I heard it is SEAGATE, 500gb 2,5" but don’t know PN, so if any of you could help me it would be great.

Frage wurde da


noch einmal gestellt.